Home > 电话会议新闻动态 > 技术文档 > IP电话多方通话的设计与实现

IP电话多方通话的设计与实现

2014/04/23 meeteasy

随着信息时代的到来,传统的通信受到了越来越多的挑战。IP电话作为未来电话通信的重要发展趋势正受到人们越来越多的关注。IP电话技术是建立在IP技术上的分组化、数字化传输技术,IP电话系统把普通电话的模拟信号转换成计算机可联人因特网传送的IP数据包,同时也将收到的IP数据包转换成声音的模拟电信号。与传统电话网络相比,IP电话通过数据网络传送语音信号,又可提供数据服务,显著降低网络运营成本,IP电话的安装布线简单,只需将IP电话与数据线连接即可,移动性较好。

1、IP语音协议介绍

VolP就是将模拟声音讯号数字化,以数据封包的形式在IP数据网络上做实时传递。VoIP可以在IP网络上传送语音、传真、视频和数据等业务。IP电话的核心与关键设备是IP网关,它把各地区电话区号映射为相应的地区网关IP地址。常用的IP语音协议包括H.323协议、SIP、MGCP和SCCP。H.323是常见的VolP标准,由ITU—T于1996年提出,原本是用于局域网路上的视讯会议,后来被应用于VolP网络电话上。H.323架构由4个元件所组成,包括终端设备、闸道器、闸道管理员、多点控制单元,可进行单点对单点或单点对多点的通讯。SIP,即会话发起协议,是IETF创建VoIP通话连接的协议标准,是IETF多媒体数据和控制体系结构的核心协议。SIP是一种应用层控制协议,用于和一个或多个参与者创建、 修改和终止会话。MGCP,即媒体闸道器控制协议,是由思科和Telcordia提议的VoIP协议,它定义了呼叫控制单元(呼叫代理或媒体闸道器)与电话闸道器之间的通信服务,允许将语音网关置于集中式呼叫代理的监控下,任何时间MGCP网关都可以依靠智能呼叫代理和语音网络呼叫。SCCP,即小型客户端控制协议,它是CISCO专用的协议,用于控制cisco IP电 话与终端设备。电话的任何交互都会引起IP电话向呼叫处理软件发送消息,随后呼叫处理软件发出设备动作指令作为响应。

2、IP电话多方通话原理

2.1 Cisco Callmanager简介

当Cisco首次进入IP电话领域时,最早提供呼叫处理层服务的产品是Cisco Callmanager。该产品几乎可以处理任何规模的语音网络,它是思科统一通信解决方案中强大的呼叫处理组件,是一个可扩展、可分布、高度可用的企业IP语音呼叫处理解决方案,可将企业电话特性和应用扩展至分组电话网络设备,如IP电话、介质处理设备、IP语音(VoIP)网关和多媒体应用。Cisco Callmanager可安装在Cisco Media Convergence Server(MCS)7800和特定第三方服务器上。

2.2 IP电话通话的基本过程

IP电话通话大致分为两个过程,包括IP电话的 注册和IP电话号码的分配。

IP电话的注册过程如下:在使用瘦站协议(sc— CP)的网络中,IP电话一旦连接到网络上并得到电力供应,就需获取IP地址参数并从CCM数据库下载一个配置文件,IP地址参数通过DHCP获得后,电话就 能从TFTP服务器中获取其配置(CNF)文件,并继续其启动过程,网络中每一台电话都应根据其MAC地 址拥有与其相关的、唯一的CNF文件,配置文件向电话提供诸如有效CCM服务器这样的信息。一旦得到 配置文件,电话同样必须获取合适的代码映像,这个下载仅发生在电话第一次注册在CCM上期间。电话会在每次注册到网络上时检测代码映像,如果必须下载新的代码映像,电话就向TFrI’P服务器发出请求, 然后重启,重新开始其初始化过程。

IP电话号码的分配过程如下:当IP电话注册成 功后,在将电话添加进网络时,为电话分配一个目录 号码(DN)可以自动或者手工进行,所有电话号码的分配都是由CCM应用程序集中处理的。在手工分配 DN时,电话通过向CCM提供MAC地址并被绑定固 定的DN;对于自动配置,CCM提供一种自动注册的特l生,该特性可在CCM中仅通过为自动注册的目标分配一个有效的DN范围来实现。

最后一旦电话获取一个DN,并成功注册在CCM上,它就可以在网络上拨打或接受呼叫。

2.3 IP电话多方通话的实现原理

Cisco callmanager服务器上的会议桥软件是一种用于提供AD—HOC和MEET—ME语音会议的软件应用程序。Meet—me会议需要为其单独分配一定范围的号码,在创建一个meet—me会议时,会议控制器选择一个号码并将其通告给组的所有成员。与会者可以调用这个号码来参加会议,前提是没超过指定会议类型的最大与会者数目,并且在会议设备中有足够的流。AD—hoc会议是由会议控制器控制的。会议控制器单独的向会议召集并添加与会者。任意数目的团体都可以加入会议,最多可到由AD—hoc规定的最大与会者数目。会议设备有两种类型:单播和多播。对于会议来说,你必须决定在任一时刻并发用户的总数量或者音频流。然后就可以创建和配置设备来支持所计算出数量的流。这些音频流可用于一个大型的会议或者rt个小型会议。例如,一个会议设备可配置支持最多2O个流,那么这个设备就能支持一个有2O 个与会者的会议,或者4个会议,每个会议有5个参与者。

3、IP电话多方通话的设计与实现

3.1 IP电话多方通话网络拓扑的设计

IP电话多方通话网络拓扑的设计
图1是我们进行IP电话多方通话设计的网络拓扑图,本拓扑模拟一个公司的总部和分部,总部以两台三层交换机Cisco 3560G为中心,使用HSRP协议提供网关冗余,Cisco Callmanager Server配置在一台独立的服务器上,两台二层交换机cisco 2960为cisco IP phone7940提供接人层功能,为避免网络中单点故障,局域网中每条链路都使用了冗余线路,并且使用了RSTP生成树协议来避免网络中环路的发生。在局域网中,通过划分语音VLAN和数据VLAN,使得语音数据可以和其他的用户数据隔离,以提供安全性和 QOS功能,同时提高了语音的质量,局域网中使用 CISCO AP 3502提供无线接人,扩展了网络边界,方便了员工的电话沟通。分部以一台二层交换机cisco 2960作为接人层设备。在总部和分部之间网络的出口路由器上配置了IPSEC VPN,保障了公司总部和分部之间通话的安全性。

3.2 IP电话多方通话的实现

本系统实现了PC上的软电话和7942G硬电话之间的多方通话,需要在路由器、交换机、服务器上进行相关配置。具体配置过程如下:

3.2.1二层交换机的配置

二层交换机上主要进行语音VLAN和数据VLAN的划分,主要配置命令如下:

S2960(config)#vlan 10
S2960(config-vlan)#name voice
S2960(config)#vlan 30
S2960(config-vlan)#name data
S2960(config)#int range f 1/3-4
S2960(config-range-if)#switchpoa mode access
S2960(config-range-if)#switchport access vlan 30
S2960(config-range-if)#switchport voice vlan 10

3.2.2三层交换机的配置

(1)创建三层交换机虚拟接口,为vlan之间提供路由选择,实现局域网vlan之间的通信。主要配置命令如下:

S3560-1(config)#ip routing
S3560-1(config)#int vlan 10
S3560-l (config-if)#ip add 192.168.10.1
255.255.255.0

(2)网关冗余协议HSRP配置

S3560-1(config)#standby 1 priority 150
S3560-1(c0nfig)#standby 1 ip 192.168.10.2
S3560-1(config)#standby l timers 3 10
S3560-1(config)#standby 1 preempt
S3560-1(config)#standby 1 track int
S3560-2(c0nfig)#standby 1 priority ll0
S3560-2(config)#standby 1 ip 192.168.10.2
S3560-2(config)#standby 1 timer 3 l0
S3560-2(config)#standby 1 preempt

(3)生成树协议配置,

S3560-1 (config)#spanning-tree vlan 10 prio 4096
S3560-2 (config)#spanning-tree vlan 10 prio 8192

(4)Etherchannel配置

S3560-1(config)#int port-channel l
S3560-1 (c0nfig)#switchport trunk encapsulation dotlq S3560-1(config)#switchportmode trunk
S3560-1(config)#int rang f0/3—4
S3560-1(config)#channel-group 1 mode on
S3560-1(config)#switchpoa trunk encapsulation dotlq S3560-1(c0n6g)#switchport mode trunk

3.2.3路由器的配置

在路由器上配置EIGRP路由协议和DHCP,使总部和分部能够互相通信。为了保证语音流量通话内容不被窃取,利用IPSEC VPN为语音数据流量进行加密。通常IPSEC是不支持传输动态路由协议的, 例如RIP、EIGRP或非IP数据流。若要在IPSEC构建的VPN网络上传输这些数据,就必须借助于GRE协议对路由协议报文进行封装,使其成为IPSEC可以处理的IP报文。

IPSec VPN的主要配置如下:
R1(config)#crypto isakmp policy 1
R1(config-isakmp)#encryption 3des
R1(config-isakmp)#authentication pre-share
R1(config—isakmp)#group 5
R1 (eonfig)#crypto isakmp key cisco address 192.168.7.2
R1 (config)#crypto ipsec transform—set myset esp-3des esp—sha—hmac
R1(config)#crypto map map 1 ipsec—isakmp
R1(config-crypto-map)#set peer 192.168.7.2
R1(config-crypto-map)#set transform—set myset
R1(config-crypto-map)#match address 101
R1(config)#interface Tunnel0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#tunnel source FastEthernet0/0
R1(config—if)#tunnel destination 192.168.7.2
R1(config—if)#access—list 101 permit gre host 192.168.6.1 host 192.168.7.2

与公司分部相连的路由器R3需要配置单臂路由,实现局域网vlan之间的通信。

3.2.4服务器的配置

服务器环境:window server 2008

软件:vmware6.0.2,CCM6.0,IE6.0

CCM在VM6.0中安装成功的界面如图2所示。

安装成功的界面
设置CCM6.0的IP地址命令:set network ip eth0 ip-add mask;
设置CCM6.0的默认网关命令:set network ip gateway;

查看已配置信息命令:show network ip。

在CCM中需要进行电话号码范围、会议通话、呼叫驻留、呼叫代答、呼叫转移等设置,它将在IP电话号码的分配、多方通话的实现中起到重要作用。

3.2.5 多方通话的测试

在多方通话系统配置完成后,需要进行实验测试。实验中,3台硬电话7942G分别获取了号码1000、1001、1002。PC上安装的cisco ip communicator软电话通过自动注册获取了号码1005,在任意一台电话上拨打某一个号码,都能够实现多方的通话,测试结果为通话质量清晰,电脑通信与IP电话通信能够无缝切换同步进行。该实验体现了IP电话应用的实用性和高效性。

4、结束语

本文在研究IP语音协议的基础上,使用cisco网络设备和服务器实现了IP电话的多方通话功能,可以满足小型企业内部的语音通信需求,为企业节约通信成本。该方案还可以在通信范围上进一步提高,如在运营商申请一个证书就可通过PSTN网络实现企业IP电话与普通手持电话进行通信,进一步提高IP电话系统的实用性。

Cisco设备, VoIP, 多方通话

如没特殊注明,文章均为好会通科技原创,转载请注明来自 http://www.meeteasy.com.cn/archives/2548.htm.

copyright 2004-2013     粤ICP备12061155号-1

Sitemap|XML|RSS|隐私政策|EN|