Home > 电话会议新闻动态 > 技术文档 > 小型企业内部网VOIP电话的构建与实现

小型企业内部网VOIP电话的构建与实现

2014/04/26 meeteasy

0、引言

某小型企业由于业务特殊性要求员工要进行大量 沟通和联系.同时为了节约开支,需要构建企业内部网 VolP电话。与拨打传统电话网通信相比.VolP电话的 最大好处就是通话没有电话费.所有的数据都是被IP 所承载的.所以不产生电话费。

企业现有的通信设备有Ciseo 2811路由器一台、 Cisco 2950交换机一台。无线AP一台等。企业现有 Cisco 7960 IP电话若干台.普通模拟电话若干台。同时 企业内部年轻员工比较多.大多有电脑、智能手机以及 平板电脑等可以安装IP电话软件的通信终端

1、企业内部网VolP电话的拓扑图

以cisco 2950交换机为中心.交换机F0/1端13与 Cisco 2811路由器FO/0端口相连 Ciseo 281l路由器作 为CallmanagerSeⅣer 交换机F0/2端口与PC以太网端 口相连 交换机F0/3端口与Cisco 7960 IP电话以太网 端口相连 交换机F0/4端1:3与Modem以太网端13相 连,Modem电话接13再与普通模拟电话接口相连。交换 机F0/5端口与无线AP以太网端口相连.无线AP再与 智能手机以及平板电脑相连
企业内部网VoIP电话的拓扑图如图1所示:

企业内部网VoIP电话的拓扑图
其中PC0对应号码1001.IP Phone0对应号码 1002,Anal0g Phone0对应号码1003,Smartphone0对应 号码1004,Tablet PC0对应号码1005。

2、CallmanagerServer的配置

(1)配置Cisco 2811路由器名称以及端1:3 IP地址。

Router(config)#hostname CallmangerSever
CallmangerSever(config)#interface fastEthernet 0/0
CallmangerSever(config-if)#ip address 1.1.1.1 255.255.255.0

CallmangerSever(config-if)#no shutdown

CallmangerSever(config—if)#exit

(2)配置Cisco 2811路由器DHCP功能。

CallmangerSever(config)#ip dhcp excluded-address 1.1.1

//IP地址1.1.1.1

CallmangerSever(config)#ip dhcp pool voip
CallmangerSever(dhcp-config)#network 1.1.1.0 255.255.255.0
CallmangerSever(dhcp-config)#default-router 1.1.1.1
CallmangerSever(dhcp-config)#option 150 ip 1.1.1.1

//思科电话设备需要从TFTP服务器下载配置文件,如果没有配置TFTP服务器,它就会向DHCP服务器发送 option 150命令请求配置信息。

CallmangerSever(dhcp-config)#exit
CallmangerSever(dhcp-config)#no ip domain-lookup

//避免输入错误命令、IP时,router以为是域名而去解析,提高响应速度。

(3)配置Cisco 2811路由器电话服务。

CallmangerSever(config)#elephony-service
CallmangerSever(config-telephony)#max-ephones 36
CallmangerSever(config-telephony)#max-ephones 36
CallmangerSever(config-telephony)#max-dn 36

//允许最大目录数

CallmangerSever(config-telephony)#ip sourec-address 1.1.1.1 port 2000

//IP电弧注册到Callmanger上通信的IP和端口号

CallmangerSever(config-telephony)#create cnf-files

//创建电话的配置信息文件

CallmangerSever(config-telephony)#exit
CallmangerSever(config)#ephone-dn 1

//设置逻辑电话目录号

CallmangerSever(config-ephone-dn)#number 1001

//设置电话号码

CallmangerSever(config)#ephone-dn 2

CallmangerSever(config-ephone-dn)#number 1002

CallmangerSever(config)#ephone-dn 3

CallmangerSever(config-ephone-dn)#number 1003

CallmangerSever(config)#ephone-dn 4

CallmangerSever(config-ephone-dn)#number 1004

CallmangerSever(config)#ephone-dn 5

CallmangerSever(config-ephone-dn)#number 1005

CallmangerSever(config-ephone-dn)#exit

CallmangerSever(config)#ephone 1

CallmangerSever(config-ephone)#mac-address 0090.D3BC.C019

//绑定MAC地址

CallmangerSever(config-ephone)#type CIPC

//CIPC为安装IP电话软件的软电话

CallmangerSever(config-ephone)#button 1:1

//电话按钮与电话目录号绑定

CallmangerSever(config)#ephone 2

CallmangerSever(config-ephone)#mac-address 0BD5.315C.7855

CallmangerSever(config-ephone)#type 7960

CallmangerSever(config-ephone)#button 1:2

CallmangerSever(config)#ephone 3

CallmangerSever(config-ephone)#mac-address 0006.2FCC.2A51

allmangerSever(config-ephone)#type ata

//ata为模拟电话

CallmangerSever(config-ephone)#button 1:3

CallmangerSever(config)#ephone 4

CallmangerSever(config-ephone)#mac-address 00D0.DF1C.32DA

CallmangerSever(config-ephone)#type CIPC

CallmangerSever(config-ephone)#button 1:4

CallmangerSever(config)#ephone 5

CallmangerSever(config-ephone)#mac-address 0001.4431.975D

CallmangerSever(config-ephone)#type CIPC

CallmangerSever(config-ephone)#button 1:5

3、交换机的配置

Switch(config)# interface FastEthernet0/3
//F0/3与Cisco 7960IP电话相连

Switch(config-if)# switchport mode access

Switch(config-if)# switchport voice vlan 1

4、无线设备的配置

(1)配置无线AP

无线AP的配置

(2)配置Smartphone

Smartphone的配置

(3)配置Tablet PC

Tablet PC的配置

5、其他设备的配置

PC Cisco 7960以及通过调制解调器连接的模拟电话都通过DHCP获取IP地址。

6、系统测试

(1)平板电脑Tablet PC0打给Cisco 7960平板电脑Tablet PC0分配电话号码是1001,Cisco 7960分配的电话号码是1002;

(2)智能手机Smartphone()打给普通模拟固定电话Analog Phone()智能手机Smartphone()分配电话号码是1004,普通模拟固定电话Analog Phone()分配的电话号码是1003.

7、结语

采用Cisco独有的Callmanager解决方案,配置Cisco 2811路由器作为Callmanager服务器,提供电话号码的注册和分配,完成电话的信令控制和通话控制。以Cisco 2950交换机为中心连接各通信终端,同时使用无线AP来连接无线设备,例如笔记本电脑、平板电脑以及智能手机等支持软iPhone的通信终端,最终实现这些通信终端的内部通话,从而构建小型企业内部网Voip电话。当然我们在构建企业内部网Voip电话时没有过多地考虑安全性,以及没能实现外出员工通过VPN拨打公司内部电话的功能,这些还需要进一步研究和探索。

平板电脑Tablet PC0给Cisco 7960拨号界面以及Cisco 7960来电显示界面 智能手机Smartphone()给普通电话拨号界面以及普通电话来电显示界面

CaUrnanager, VolP

如没特殊注明,文章均为好会通科技原创,转载请注明来自 http://www.meeteasy.com.cn/archives/2741.htm.

copyright 2004-2013     粤ICP备12061155号-1

Sitemap|XML|RSS|隐私政策|EN|